const regex = /(?<!\d\s)(?<!\d)(mil)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d\\s)(?<!\\d)(mil)\\b', 'gm')
const str = `esta a mil o a 25 mil 500 millas de la ciudad de milan
mil o mas para pasar! y tu tienes menos de mil
hace casi mil o 2mil anos aparecio un fenomeno legendario tan solo a millas de aqui`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}