#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\d{1,2})\s([a-z]{3})\.?\s(\d{1,2}:\d{1,2})\s-\s([a-z]+):\s(.+)"
Local $sString = "11 jan. 22:20 - Dam: Ik zal d'r zijn"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")