const regex = /(\d{1,2})\s([a-z]{3})\.?\s(\d{1,2}:\d{1,2})\s-\s([a-z]+):\s(.+)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2})\\s([a-z]{3})\\.?\\s(\\d{1,2}:\\d{1,2})\\s-\\s([a-z]+):\\s(.+)', 'i')
const str = `11 jan. 22:20 - Dam: Ik zal d'r zijn`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}