re = /(\d{1,2})\s([a-z]{3})\.?\s(\d{1,2}:\d{1,2})\s-\s([a-z]+):\s(.+)/i
str = '11 jan. 22:20 - Dam: Ik zal d\'r zijn'
# Print the match result
str.match(re) do |match|
puts match.to_s
end