import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ ]*(.*)\\n[ ]*- ([0-9]{1,5}) bytes:\\n(?:[ ]*([0-9A-F]{8}) (?:([0-9A-F]{2}) ){8} (?:([0-9A-F]{2}) ){8} .{16}\\n)*[ ]*([0-9A-F]{8}) (?:([0-9A-F]{2}| ) ){8} (?:([0-9A-F]{2}| ) ){8} .{0,16}\\n";
final String string = " Sending data on COM port COM2: - 5 bytes:\n"
+ " - 5 bytes:\n"
+ " 00000000 10 5B FE 59 16 .[.Y.\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}