import Foundation
let pattern = #"[ ]*(.*)\n[ ]*- ([0-9]{1,5}) bytes:\n(?:[ ]*([0-9A-F]{8}) (?:([0-9A-F]{2}) ){8} (?:([0-9A-F]{2}) ){8} .{16}\n)*[ ]*([0-9A-F]{8}) (?:([0-9A-F]{2}| ) ){8} (?:([0-9A-F]{2}| ) ){8} .{0,16}\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Sending data on COM port COM2: - 5 bytes:
- 5 bytes:
00000000 10 5B FE 59 16 .[.Y.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)