use strict;
my $str = ' Sending data on COM port COM2: - 5 bytes:
- 5 bytes:
00000000 10 5B FE 59 16 .[.Y.
';
my $regex = qr/[ ]*(.*)\n[ ]*- ([0-9]{1,5}) bytes:\n(?:[ ]*([0-9A-F]{8}) (?:([0-9A-F]{2}) ){8} (?:([0-9A-F]{2}) ){8} .{16}\n)*[ ]*([0-9A-F]{8}) (?:([0-9A-F]{2}| ) ){8} (?:([0-9A-F]{2}| ) ){8} .{0,16}\n/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}