re = /[ ]*(.*)\n[ ]*- ([0-9]{1,5}) bytes:\n(?:[ ]*([0-9A-F]{8}) (?:([0-9A-F]{2}) ){8} (?:([0-9A-F]{2}) ){8} .{16}\n)*[ ]*([0-9A-F]{8}) (?:([0-9A-F]{2}| ) ){8} (?:([0-9A-F]{2}| ) ){8} .{0,16}\n/mi
str = ' Sending data on COM port COM2: - 5 bytes:
- 5 bytes:
00000000 10 5B FE 59 16 .[.Y.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end