package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z](?:[a-z]|\b[,.'-]\b)+(?: [A-Z](?:[a-z]|\b[,.'-]\b)+)*$`)
var str = `Jane Doe
Foo Bar
bar bar
A..............
A, , ... `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}