$re = '/^[A-Z](?:[a-z]|\b[,.\'-]\b)+(?: [A-Z](?:[a-z]|\b[,.\'-]\b)+)*$/m';
$str = 'Jane Doe
Foo Bar
bar bar
A..............
A, , ... ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);