import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z](?:[a-z]|\\b[,.'-]\\b)+(?: [A-Z](?:[a-z]|\\b[,.'-]\\b)+)*$";
final String string = "Jane Doe\n"
+ "Foo Bar\n"
+ "bar bar\n"
+ "A..............\n"
+ "A, , ... ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}