re = /^[A-Z](?:[a-z]|\b[,.'-]\b)+(?: [A-Z](?:[a-z]|\b[,.'-]\b)+)*$/m
str = 'Jane Doe
Foo Bar
bar bar
A..............
A, , ... '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end