# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^regio\/([^\/]+)\/([^\/]+)$/regio\/$1\/?var=$2/mg;t' <<< "regio/bar/foo
regio/something/blabla
"