re = /^regio\/([^\/]+)\/([^\/]+)$/m
str = 'regio/bar/foo
regio/something/blabla
'
subst = 'regio/$1/?var=$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result