use strict;
my $str = 'regio/bar/foo
regio/something/blabla
';
my $regex = qr~^regio/([^/]+)/([^/]+)$~mp;
my $subst = 'regio/$1/?var=$2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";