$re = '~^regio/([^/]+)/([^/]+)$~m';
$str = 'regio/bar/foo
regio/something/blabla
';
$subst = "regio/$1/?var=$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;