using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/.+\/.+\/.+\/([0-9]+)";
string input = @"http://novo.sos-admins.com/aplicacoes/mysql/179-acesso-remoto-ao-mysql.html";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}