$re = '/\/.+\/.+\/.+\/([0-9]+)/';
$str = 'http://novo.sos-admins.com/aplicacoes/mysql/179-acesso-remoto-ao-mysql.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);