#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http:\/\/(?:[^\/\n]*\.)*google\.com(?:\/[^\n]*)?$"
Local $sString = "http://test.google.com/" & @CRLF & _
"http://google.com/" & @CRLF & _
"http://test.google.com" & @CRLF & _
"http://.google.com/" & @CRLF & _
"http://one.more.test.google.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")