package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http:\/\/(?:[^\/\n]*\.)*google\.com(?:\/[^\n]*)?$`)
var str = `http://test.google.com/
http://google.com/
http://test.google.com
http://.google.com/
http://one.more.test.google.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}