#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\(?\$([1-9][,\d]*(?:\.\d\d)?)\)?$"
Local $sString = "$150.00" & @CRLF & _
"($145.00)" & @CRLF & _
"dssddssda" & @CRLF & _
"$15" & @CRLF & _
"105" & @CRLF & _
"$55.44" & @CRLF & _
"$1,000.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")