using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\(?\$([1-9][,\d]*(?:\.\d\d)?)\)?$";
string input = @"$150.00
($145.00)
dssddssda
$15
105
$55.44
$1,000.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}