package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(?\$([1-9][,\d]*(?:\.\d\d)?)\)?$`)
var str = `$150.00
($145.00)
dssddssda
$15
105
$55.44
$1,000.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}