$re = '/^\(?\$([1-9][,\d]*(?:\.\d\d)?)\)?$/m';
$str = '$150.00
($145.00)
dssddssda
$15
105
$55.44
$1,000.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);