using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\()\bAPPLE\b(?![\w\s]*[\)])";
string input = @"APPLE
APPLE APPLE
APPLE (APPLE)
(BANANA APPLE)
(BANANA APPLE ORANGE)
(APPLE ORANGE BANANA)
(ORANGE APPLE
)
(ORANGE APPLE) APPLE";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}