re = /(?<!\()\bAPPLE\b(?![\w\s]*[\)])/
str = 'APPLE
APPLE APPLE
APPLE (APPLE)
(BANANA APPLE)
(BANANA APPLE ORANGE)
(APPLE ORANGE BANANA)
(ORANGE APPLE
)
(ORANGE APPLE) APPLE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end