$re = '/(?<!\()\bAPPLE\b(?![\w\s]*[\)])/';
$str = 'APPLE
APPLE APPLE
APPLE (APPLE)
(BANANA APPLE)
(BANANA APPLE ORANGE)
(APPLE ORANGE BANANA)
(ORANGE APPLE
)
(ORANGE APPLE) APPLE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);