import re
regex = re.compile(r"(?<!\()\bAPPLE\b(?![\w\s]*[\)])")
test_str = ("APPLE\n"
"APPLE APPLE\n"
"APPLE (APPLE)\n"
"(BANANA APPLE)\n"
"(BANANA APPLE ORANGE)\n"
"(APPLE ORANGE BANANA)\n"
"(ORANGE APPLE\n"
")\n"
"(ORANGE APPLE) APPLE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")