#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".{10,20}?([\w.]+).{10,20}word_to_match.{0,15}"
Local $sString = "<span data-attr="something" attr1="" ><i>other_word</i></span>" & @CRLF & _
"<span data-attr="required" attr1="" ><i>word_to_match</i></span>" & @CRLF & _
"<span data-attr="something1" attr1="" ><i>some_other_word</i></span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")