package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.{10,20}?([\w.]+).{10,20}word_to_match.{0,15}`)
var str = `<span data-attr="something" attr1="" ><i>other_word</i></span>
<span data-attr="required" attr1="" ><i>word_to_match</i></span>
<span data-attr="something1" attr1="" ><i>some_other_word</i></span>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}