import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".{10,20}?([\\w.]+).{10,20}word_to_match.{0,15}";
final String string = "<span data-attr=\"something\" attr1=\"\" ><i>other_word</i></span>\n"
+ "<span data-attr=\"required\" attr1=\"\" ><i>word_to_match</i></span>\n"
+ "<span data-attr=\"something1\" attr1=\"\" ><i>some_other_word</i></span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}