using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{10,20}?([\w.]+).{10,20}word_to_match.{0,15}";
string input = @"<span data-attr=""something"" attr1="" ><i>other_word</i></span>
<span data-attr=""required"" attr1="" ><i>word_to_match</i></span>
<span data-attr=""something1"" attr1="" ><i>some_other_word</i></span>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}