#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\$\d+(?:,\d+)*(?:\.\d+)*)|([^,\n]+)"
Local $sString = "1000,ABC Group ,$10,000.21,10000.21,20000.123,30000.123,XYZ,01/01/2015,01/10/2015,123456789,1 ,PQR,1000" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"aaa,bbb,$33,222,ccc,$22,000" & @CRLF & _
"" & @CRLF & _
"aaa,$12,000,12345,bbb,56789,ccc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")