const regex = /(\$\d+(?:,\d+)*(?:\.\d+)*)|([^,\n]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\$\\d+(?:,\\d+)*(?:\\.\\d+)*)|([^,\\n]+)', 'gm')
const str = `1000,ABC Group ,\$10,000.21,10000.21,20000.123,30000.123,XYZ,01/01/2015,01/10/2015,123456789,1 ,PQR,1000
aaa,bbb,\$33,222,ccc,\$22,000
aaa,\$12,000,12345,bbb,56789,ccc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}