// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\$\d+(?:,\d+)*(?:\.\d+)*)|([^,\n]+)").unwrap();
let string = "1000,ABC Group ,$10,000.21,10000.21,20000.123,30000.123,XYZ,01/01/2015,01/10/2015,123456789,1 ,PQR,1000
aaa,bbb,$33,222,ccc,$22,000
aaa,$12,000,12345,bbb,56789,ccc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}