$re = '/(\$\d+(?:,\d+)*(?:\.\d+)*)|([^,\n]+)/m';
$str = '1000,ABC Group ,$10,000.21,10000.21,20000.123,30000.123,XYZ,01/01/2015,01/10/2015,123456789,1 ,PQR,1000
aaa,bbb,$33,222,ccc,$22,000
aaa,$12,000,12345,bbb,56789,ccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);