$re = '/(?:Carrier )?Tracking Number\s*:?\s*([A-Z0-9]+)/m';
$str = 'Tracking Number
1ZA828Y12313205351
Carrier Tracking Number : 582612345988';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);