using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:Title|Starring|Directed by|Price|Opening|Showtimes|Year)\:)(.+)";
string input = @"Title: The Independents
Year: 2015
Starring: Ronald Russo, Kevin Spielberg, Holley Spacey, James D. Frail
Directed by: James Aranofsky
Genre: Drama, Comedy
Price: $10
Opening: 4/15
Showtimes: 10a, 1p, 4:15p
Summary: Joe and Jane are a couple who decide to go independent. There is just one problem: neither of them are actually employed the first place. Hillarity ensues.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}