import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:Title|Starring|Directed by|Price|Opening|Showtimes|Year)\\:)(.+)";
final String string = "Title: The Independents\n"
+ "Year: 2015\n"
+ "Starring: Ronald Russo, Kevin Spielberg, Holley Spacey, James D. Frail\n"
+ "Directed by: James Aranofsky\n"
+ "Genre: Drama, Comedy\n"
+ "Price: $10\n"
+ "Opening: 4/15\n"
+ "Showtimes: 10a, 1p, 4:15p\n"
+ "Summary: Joe and Jane are a couple who decide to go independent. There is just one problem: neither of them are actually employed the first place. Hillarity ensues.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}