const regex = /(?:(?:Title|Starring|Directed by|Price|Opening|Showtimes|Year)\:)(.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:Title|Starring|Directed by|Price|Opening|Showtimes|Year)\\:)(.+)', 'g')
const str = `Title: The Independents
Year: 2015
Starring: Ronald Russo, Kevin Spielberg, Holley Spacey, James D. Frail
Directed by: James Aranofsky
Genre: Drama, Comedy
Price: \$10
Opening: 4/15
Showtimes: 10a, 1p, 4:15p
Summary: Joe and Jane are a couple who decide to go independent. There is just one problem: neither of them are actually employed the first place. Hillarity ensues.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}