#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\h*\(.*?(?:picture|see|lorem).*?\))"
Local $sString = "Hello world (see below)." & @CRLF & _
"Lorem ipsum (there is a picture here) world!" & @CRLF & _
"Attack on titan (is lorem) great but (should not be removed)." & @CRLF & _
"" & @CRLF & _
"Here is one(see should be removed too) world!" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")