$re = '~(\h*\(.*?(?:picture|see|lorem).*?\))~';
$str = 'Hello world (see below).
Lorem ipsum (there is a picture here) world!
Attack on titan (is lorem) great but (should not be removed).
Here is one(see should be removed too) world!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);