package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\h*\(.*?(?:picture|see|lorem).*?\))`)
var str = `Hello world (see below).
Lorem ipsum (there is a picture here) world!
Attack on titan (is lorem) great but (should not be removed).
Here is one(see should be removed too) world!
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}