import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\h*\\(.*?(?:picture|see|lorem).*?\\))";
final String string = "Hello world (see below).\n"
+ "Lorem ipsum (there is a picture here) world!\n"
+ "Attack on titan (is lorem) great but (should not be removed).\n\n"
+ "Here is one(see should be removed too) world!\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}