// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\n? */{2,} .*").unwrap();
let string = "<!DOCTYPE html>
<html xmlns=\"http://www.w3.org/1999/xhtml\" xml:lang=\"en\" lang=\"en\">
<head>
<title>Online regex tester and debugger: JavaScript, Python, PHP, and PCRE</title>
// comment
<meta name=\"keywords\"// content=\"javascript,regex,regular expression,debugger,explainer,helper,tester,match,pcre,python,editor\">
<meta name=\"description\" content=\"Onli//ne regex tester, debugger with highlighting for PHP, PCRE, Python and JavaScript.\">
<meta name=\"author\" content=\"Firas Dib\">
// this is a comment
<meta property=\"twitter:card\" content=\"summary\">
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}