#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=class\s)\s*(.+?)(?=\s*\{)"
Local $sString = "class Mango {" & @CRLF & _
"class mango" & @CRLF & _
"mango {" & @CRLF & _
"class _Mango$ {" & @CRLF & _
"class ‿Mango{" & @CRLF & _
"class mango{" & @CRLF & _
"class mango {" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")