$re = '/(?<=class\s)\s*(.+?)(?=\s*\{)/';
$str = 'class Mango {
class mango
mango {
class _Mango$ {
class ‿Mango{
class mango{
class mango {
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);