re = /(?<=class\s)\s*(.+?)(?=\s*\{)/
str = 'class Mango {
class mango
mango {
class _Mango$ {
class ‿Mango{
class mango{
class mango {
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end