using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=class\s)\s*(.+?)(?=\s*\{)";
string input = @"class Mango {
class mango
mango {
class _Mango$ {
class ‿Mango{
class mango{
class mango {
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}