package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(un|deux|trois|quatre|cinq|six|sept|huit|neuf|dix|quinze|vingt|trente)\s+(mois|années|année|ans|an)\s+(?:d'(emprisonnement)|de (réclusion criminelle)))|(?:de\s+la\s+(réclusion)\s+criminelle\s+à\s+(perpétuité))`)
var str = `Le vol est puni de la réclusion criminelle à perpétuité et de 150 000 euros d'amende lorsqu'il est précédé, accompagné ou suivi soit de violences ayant entraîné la mort, soit de tortures ou d'actes de barbarie. `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}